Intermittent Slowness

Incident Report for Arbor Finance

Resolved

The issue has been fully resolved, and current monitoring indicates that the service is operating normally. We will continue to keep a close watch to ensure stability. A detailed analysis is underway to understand the root cause and prevent similar incidents in the future.
Posted Apr 15, 2025 - 06:47 BST

Update

We are continuing to monitor for any further issues.
Posted Apr 15, 2025 - 06:47 BST

Monitoring

We have observed no occurrences of the issue in the past few hours, and our monitoring indicates that the service is returning to normal. We will continue to monitor the situation closely to ensure continued stability. Thank you for your patience.
Posted Apr 11, 2025 - 10:47 BST

Update

Our team is actively investigating the slowness and occasional 500 errors that some customers have been experiencing. We truly appreciate your patience and understanding during this time. We will share further updates at the earliest.
Posted Apr 10, 2025 - 14:17 BST

Update

Please be aware that we will be conducting emergency maintenance starting at 12:00 PM today. Arbor Finance may be temporarily unavailable during this window, with the outage expected to last up to 15 minutes. Our team will be closely monitoring the process to ensure minimal disruption.
Posted Apr 10, 2025 - 11:31 BST

Investigating

We are sorry but we have had some slowness and occasional error 500 reports. Our team is investigating. Please bear with us whilst we work to fix this. We understand that this is a busy time of the year for our customers and this is our top priority.
Posted Apr 10, 2025 - 09:54 BST
This incident affected: Arbor Finance.